FiiO Forums

 Retrieve Password
Register Now
/Sign In
Search
!show!: 32511|Reply: 20

What to do if “Update Media library” on the X5II/X3II/X5/X1 causes hangups?

FiiO Fans

digest
2
posts
864
F-Coin
4738
Audio Sources
X1
AMPs
E12
regtime
2013-5-10
Post time 2014-10-25 16:32:38 |Show all posts |
Edited by FiiO at 2018-6-6 20:06

Q: What to do if “Update Media library” on the X5 2nd gen/X3 2nd gen/X5/X1 causes hangups?

A: If the
X5 2nd gen/X3 2nd gen/X5/X1 hangs while updating the media library, it will still hang on any subsequent attempt if no changes are made.  The first thing to try is to eject the micro SD card(s), update the media library with no cards loaded to clear the database, insert the card(s) again and try updating again.  If the update still hangs, then it is caused by certain problems on the card(s) or certain problems with files on the cards.  Please try the following:

1. Examine the SD card(s) on the computer and delete files with .log extension or any other non-music files from the card(s) and run the media library update again
2. If all your music files are stored directly under the root directory of the card, try splitting them into smaller folders (around 100-200 songs in each folder)
3.
Format the SD card with the player (System settings->Storage formatting) or format it to exFAT on computer then re-transfer files to it and update again.
4. Replace the card with another one (a Sandisk class 10 card is recommended)
5. If using the X5 2nd gen, try downgrading the firmware to the FW1.2.

If the update still hangs, it means the problem might be caused by the corrupted files, then please first try using the software tool "tagscan" (>>
download link) to scan and locate the corrupted files.

If the "tagscan" tool cannot find the corrupted files, please try the following methods to locate and clear these files.

(1) remove the cards and do a library update (clears the database)
(2) move half of the songs out of the card (e.g. half of the folders), insert the card and try the library update again.
(3) if the update succeeds:
a. add half of the folders you moved out back into the card (for a total of 3/4 of the original total) and try again
if the update in (2) fails:
b. move out half of the remaining folders (for a total of 1/4 of the original total) and try again
if the update in (b) succeeds:
i. add half of the folders you moved out in (b) back into the card and try again
...
Basically the idea is to use a binary tree elimination to find song(s) or file(s) that are causing issues with the library scan.

Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
16
F-Coin
90
Audio Sources
X5
AMPs
NONE
Head Gears
Klipsch
regtime
2014-12-12
Post time 2014-12-19 07:07:29 |Show all posts |
Edited by Mbrust at 2014-12-19 07:16

Can you have English versions of all these downloads from pan.Baidu.com


For some reason as I add FLAC files to a SD card with existing music and plenty of space these files get copied over. but once I update MEDIA Library on the X5 they get Wiped out and corrupted.

Using Windows Check disk it turns all the album folders in to Empty files and stoes all the original music data in a the Hidden Error folder. All this is unrecoverable so has to be deleted.

Try again and this repeats.

Music files are good as I have 3 players that can all play them.
Brand new rips.

I have over 100Gb of room.

It is like it does not like my music and will not allow it on.
I have latest firmware 2.2
Reply

Use magic Report

FiiO Fans

digest
2
posts
864
F-Coin
4738
Audio Sources
X1
AMPs
E12
regtime
2013-5-10
Post time 2014-12-19 17:08:36 |Show all posts |
Edited by Yellow at 2015-7-22 16:19
Mbrust replied at 2014-12-19 07:07
Can you have English versions of all these downloads from pan.Baidu.com

1. Have you already formatted the micro SD card by the X5 directly?
2. After following the above ways step by step, they can't help solve this problem?
3. Which kind of formats are those music files? You can play all of them in the X5 by "Browse files"?
4. How about trying to upgrade your X5 to the newer firmware FW2.36beta: FW2.36beta?

BTW, if you can't download that tool SAMediaScanner, pls try this new link:click here.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
16
F-Coin
90
Audio Sources
X5
AMPs
NONE
Head Gears
Klipsch
regtime
2014-12-12
Post time 2014-12-20 02:13:35 |Show all posts |
1. yes I used X5 to format and even tried it as NTFS using LAptop to format. Similar issue except when NFTS it locks up the X5 and PIA to find which files got corrupted.

2. the poor SD card has been formated about 10 times in the past 2 weeks trying to get this to work. Each time I copy over in different order and the songs with errors changes as the first batch takes but after that in each bactch copied over afterwards less and less are playable and added to media library. until finally none are.
3. On this card I am trying to transfer over FLAC files only onto one card. I have a second card which is not in X5 but loaded with MP3. Tried that Card initially and it had same issue.

4. I will try this. as my next step is new SD cards??

Thanks for Scanner download and it finds error with files but only lists one at a time so after you run and delet corrupt file you file you have to run again and delete 1 more and runa again until all are gone so this takes a long time would be better if this software could list them in a group or have an option to delete them for me.

Thanks for Help
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
16
F-Coin
90
Audio Sources
X5
AMPs
NONE
Head Gears
Klipsch
regtime
2014-12-12
Post time 2014-12-20 07:55:25 |Show all posts |
Same issue.

Here is what card looks like after loading more songs.
Updating medialibrary.
Then watching it not count all the songs.
Remove card
insert into Laptop and see attached for folder view.

Please note some albums inside some of the artist folders which look good are also empty and white boxes.

Pure random and never the same ones.
Frustrating to say the least.

SOngs files on lap top still playing with Foobar and windows media player.
only times they wont is once the music is put on card and card inserted into X5.

Like the X5 ruins files or something.

I can load on to card and play files but ones I remove from laptop and put card into X5 and turn on and update library... they get ruined.

What is up?

!attach_nopermission_notice!

You have to Login to download or view attachment(s). No Account?

Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
11
F-Coin
110
Audio Sources
x5
AMPs
e17
regtime
2014-12-22
Post time 2014-12-22 23:11:39 |Show all posts |
I recently bought my X5 with 2 x 128GB sandisk sd cards. I flashed to firmware 2.36 beta. I formatted the card inside the X5. Next I connected the cards to my pc and copied my music collection on to them. I have almost 32000 files mostly in AAC format (m4a) which I ripped from CD using winamp over the last 10 years. So I was not happy when I tried to update the media library in X5 and it freeze.
So I did research. Maybe this is faulty sd card. I tried different cards - same problem. Then I found this thread. I followed the suggestion the first post. Using this binary tree elimination I could finally find at least one folder containing files that caused hanging. But I have a large collection, so it would take me months to go through all files and eliminate the bad ones.
I tried SAMediaScanner but it only support mp3.
I suspect that the problem is with the meta data tags, but nothing is obvious from the "bad" files I found, and I want some way to identify all the bad files quickly.
Then almost by accident I discovered TagScan http://www.xdlab.ru/en/
With this program I did not figure out how to find the bad tags, but I was able to retag my whole collection very quickly without losing any meta data.
And that was all I needed. After that I copied all my collection to the cards again. This time when I update the media library, after 45 minutes 31800 files detected!!!
So I thought I would post here for anybody else having issues. It might give you hope.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
16
F-Coin
90
Audio Sources
X5
AMPs
NONE
Head Gears
Klipsch
regtime
2014-12-12
Post time 2014-12-25 21:39:12 |Show all posts |
THanks DJX
I will try that as I wait on my new 128GB SD card from Sandisk this time.

I hope this works as I am frustrated.

Reply

Use magic Report

FiiO Fans

digest
2
posts
864
F-Coin
4738
Audio Sources
X1
AMPs
E12
regtime
2013-5-10
Post time 2014-12-26 10:39:38 |Show all posts |
djx replied at 2014-12-22 23:11
I recently bought my X5 with 2 x 128GB sandisk sd cards. I flashed to firmware 2.36 beta. I formatte ...

WOW, thanks for your sharing this information! Good job! {:3_48:}
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
16
F-Coin
90
Audio Sources
X5
AMPs
NONE
Head Gears
Klipsch
regtime
2014-12-12
Post time 2014-12-26 21:47:01 |Show all posts |
DJX what exactly did you do in XDLAB?

I mean I ran it.
Loaded all my songs.
Highlighted all.
When to tag thingy and remove comments and did a save all

Is that all you did?
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
16
F-Coin
90
Audio Sources
X5
AMPs
NONE
Head Gears
Klipsch
regtime
2014-12-12
Post time 2014-12-28 04:35:55 |Show all posts |
Still have issue but now I have ruled out the X5.

Put card in Laptop via USB holder or SD card holder.
Copy files over.
all copy over.
Eject media.
Then reinstall and try to load up in Fubar.
Some load others do not.
Those that dont when I go click on file and hit PLAY with Fubar fubar says corrupted file.
but if I go to original it is fine and not corrupted or if I check file before I eject it is fine and plays.

something happens when media is ejected from computer. I use both right click and eject and the little tray thing.

I have card formated with X5 or NTFS with laptop same thing.
Seems to be the same sets of filesfrom the same albums. but what is weird some of the files from an album will copy over and be OK.

Is it maybe a FLAC thing?

I am going to convert them to WAV and try that.

anyones help is appreciated as I am going nuts trying to figure out.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
11
F-Coin
110
Audio Sources
x5
AMPs
e17
regtime
2014-12-22
Post time 2014-12-28 15:46:28 |Show all posts |
Mbrust, after launching the tagScanner program I browsed and selected the root folder of my music library, with "search subFolders" checked. Then I selected the "TAG editor" tab and selected all my music files in the main window. On the top right hand side, in the "text transform" section , above where the tag info is displayed, I checked all the boxes - " change case", "standard values" and so on, leaving the default option for each. And finally I clicked "save" in the lower right corner (next to "remove"). That was it. After I recopied the files to the sd card, the x5 medial library was able to update without freezing.

It is worth noting that the tagScanner process changes the actual files - this was not a concern for me since I have the original CDs - but maybe people would consider making a backup the originals just in case.

I hope you figure out how to get your flacs working too.

David
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
16
F-Coin
90
Audio Sources
X5
AMPs
NONE
Head Gears
Klipsch
regtime
2014-12-12
Post time 2014-12-29 05:37:10 |Show all posts |
Still have issues and it is not the files well I do no think so as I have use many programs to check the files and tags etc.

What happens is I copy them over in batches of say 4gb or so.
and usually the first batch will work but parts of the second batch and any other batch do not work and have file errors.
I even change the content of the batches,

So one time I load a file and it is bad.
Fromat card and reload some of the bad ones from last time first and they are fine but the ones that worked previously do not work any more.

ARGGGGGGGGGGGGGGGGGGGGGG

I am going nuts searching for solution.

This time I am trying:
Formated in X5.
Loading all 42gb of files (about 1800 songs) in 5 batches. and then I will eject.

My Mp3 card had no problems but has less file space.

I wonder if WIN 7 hates the 128GB card and ruins it after so many files get on it.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
11
F-Coin
110
Audio Sources
x5
AMPs
e17
regtime
2014-12-22
Post time 2014-12-30 20:26:34 |Show all posts |
Yes, very frustrating. I was on win7 too though. I think it is important to format the card inside the X5. When I formatted on the pc the card was not recognised by the X5.

I put approx 20000 files on a 128GB card. Those files are in folders - 10 to 20 files per folder on average. I filled the card by copying in batches of approx 4GB per batch (which is roughly 40 of those folders).

But I guess your flac and wav files are much larger. Maybe that is an issues that I have not faced yet.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
16
F-Coin
90
Audio Sources
X5
AMPs
NONE
Head Gears
Klipsch
regtime
2014-12-12
Post time 2014-12-30 22:44:16 |Show all posts |
Formated in X5 again.
Tried using Foobar to copy over to X5 connected on USB cable
Took 36 Hours.! yeah fo hours for 40.6 Gb.
No files just all songs in root directory.

Finally after 2 days
Eject X5.
Update Media
ONly 319 songs copied over or 8.2 GB.

arggggggggggggggggg....

They were all there before eject.

Something about ejecting ruins everything.

Win 7 64bit.

I am stumped.
Google issue and see on some phones they have issue but was always related to device which I do not believe any more as it happens before I put card into X5.

I wonder if it is a file size issue.
They run from 4Mb to 120Mb Most run from 20-60Mb.

Files are good per FLAC Audio File tester downloaded from Flac site.

I think I may try another Lossless file type WAV.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
16
F-Coin
90
Audio Sources
X5
AMPs
NONE
Head Gears
Klipsch
regtime
2014-12-12
Post time 2014-12-31 01:59:19 |Show all posts |
THink I figured it out.

3 Fake CARDS from 3 different vendors.
seems once they get close to 8Gb anything added after gets corrupted.

Guess the simple test software I used is junked and now I am running H2testw which can be easily found on the web... It is slow as for the first card is says 23 hours left for testing.

But I got out magnifying glass and read the back and notice the 3 cards from 3 different vendors have very similar part numbers but none have 128 in the PN all have just an 8 which just makes me MAD!

googled these pn and find other have them and have same issue; 8gb max.

So off to complain and ask for my money back (miracles can happen this time of year).

Then I am going to local Wally wal Mart World to buy the largest SD card they have.

SUGGESTION to FIIO.

OFFER SD cards with the device; ones that work as an option.
you make money and we get good cards.

Well give me a few days to try this again but I am pretty sure I was scammed.

Thanks All and learn from my mistakes.
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
3
F-Coin
6
Audio Sources
fiio
AMPs
2
regtime
2015-7-17
Post time 2015-7-17 03:29:36 |Show all posts |
What are we supposed to do if you still can't update the library with the cards removed?  That's not a card problem, that's a device problem.
ALl my updates fail, with or without cards inserted.  I can't even use my device and I've seen no suggestions on how to deal with it.
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
1
F-Coin
3
Audio Sources
FiiO X3 and X5ii
AMPs
FiiO E12
regtime
2015-8-12
Post time 2015-8-12 14:43:33 |Show all posts |
I just got an X5ii and had a problem with one of the two cards I wanted to use.  The update would go through about 1853 files and then stop.  The other card was fine on its own.  The problem seems to be related to files on the card that are not music files.  These included .log files that my ripping software created when I ripped CD's to FLAC.  I used some advanced file search software call Dfind on my Mac and cleaned out all the spurious files.  Everything worked fine after that.

Use care when copying files to try to avoid this issue.  My other card had only downloaded FLAC files and was clean as far as the update went.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
1
F-Coin
155
Audio Sources
FiiO X5ii
AMPs
Onkyo
regtime
2016-12-4
Post time 2016-12-5 01:00:36 |Show all posts |
Mbrust replied at 2014-12-19 07:07
Can you have English versions of all these downloads from pan.Baidu.com

Unfortunately it doesn't work.
I had TONs of trials (128Gb, 32Gb the acquired another 128Gb to be sure not SDCard fault, back to firmware 1.2 again with 2.1).
I formatted the SDCard (128Gb) on X5ii and copied all file on it: still hangs
I tried to erase half of albums, the another quarter and finally I left only 5 albums: still hangs.
So I erased all, but 2 albums so it worked. At this time I put on another album -> hangs.
Of course I reset default factory more than once, but I suppose I doesn't work.
My question is: how can I reset COMPLETELY the X5ii memory ? I suppose that there is something into memory that also factory reset doesn't clear.
Thanks
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
1
F-Coin
11
Audio Sources
X5 ii
AMPs
E12
Head Gears
Sony MDR 1A
regtime
2017-1-29
Post time 2017-1-29 20:12:21 |Show all posts |
Edited by NFN at 2017-1-31 02:44

Hope this helps people who come across this issue. Got a sandisk 128GB in slot 1 and a Memorex 64GB in slot 2. Both class 10. Wavs/flac on 128 card and mp3 on 64GB card. Kept seeing the same thing. it would always "hang" on 6224 songs.
Did all mentioned in earlier posts. And still got the same. So tried one card at a time the 128GB appear to freeze after hitting 1022 songs but noticed that after about 30 second the update successful message appeared. I then put the 64GB card in and did another update. It stopped at the 6224 songs point again so I just left it alone and after about 5 mins the update successful appeared.
What made it looked like a hang was the fact the battery charging indicators stops after the file count stops and all buttons become unresponsive.
I worked out that I did not need to do the id tag changes, and the only thing needed was to remove any non music related file from the cards.

So when the update track count stops. Just leave the X5 alone. After a large track count it needs time to write the media library database, which can take several minutes.

Personally I don't use ID tags and play by folder or playlist. So it wouldn't have bothered me too much. But after the first hang I thought I'd try to find out what is happening. 6224 songs is a lot of info to extract from the files and write to the database. So you could considering the count as the data extraction period and the "hang" as the write period. Which will vary depending how many music files there are and the size of their tags.

Having done this a couple times now, this does seem to be the case. I deleted several folders to reduce the song count slightly. On update the count stopped earlier (6112 songs in this case) and it did exactly the same thing again, The write period was about the same length of time before update successful appeared.

I would guess that if you have 2 off 256GB card installed and both full of songs. The library update process could take up to an hour maybe more,

Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
11
F-Coin
116
Audio Sources
FLAC
AMPs
Pioneer
regtime
2017-1-1
Post time 2017-3-2 20:12:10 |Show all posts |
Hi,
where do you find out the files that have errors from mediascanner?
It told me there were some errors but no info on the screen it just finished the scan and said 20 files with errors.
Is there a log saved somewhere?
Reply

Use magic Report

You have to log in before you can reply Login | Register Now

About FiiO|Warranty|Contact Us|FiiO Forums  

GMT+8, 2020-12-5 02:39 , Processed in 0.028891 second(s), 23 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

Top