FiiO Forums

 Retrieve Password
Register Now
/Sign In
Search
!show!: 706|Reply: 5

X3 1st gen, no equalizer & won't play my .flac files.

Register Member

Rank: 2

digest
0
posts
32
F-Coin
123
Audio Sources
na
AMPs
no
regtime
2016-9-27
Post time 2018-10-29 10:56:35 |Show all posts |
My old X3 1st gen that i've used for a number of years now is almost on it's last legs. About a year ago i bought another of the same model and generation. [This is because i prefer the sound to the 2nd gen.]
So i dug out this replacement player earlier today and the display is different than my original one.
This one doesn't have a 5-band equalizer and it won't play a majority of my flac files, the message reads file is not supported. How can it play some flac files but not others?
I checked the firmware and it says it has 3.0. My original has the later 3.4. So i downloaded the 3.4 firmware from this site.
I then extracted what was in the zip file which is X3.fw.
Am i supposed to drag the X3.fw file into the internal memory of my player, is that how it gets updated? I did try this a few minutes ago, however when i looked to see if the firmware had been updated in the player's settings it still says 3.0 and not 3.4.
I also downloaded the usb dac driver v3.34.0, although i have no idea if it is needed for my replacement player or not?

As you can tell i'm not very good with anything technical at all, even basic stuff. I really need some help please.
Thanks.
Reply

Use magic Report

Customer Service

Rank: 5Rank: 5

digest
0
posts
370
F-Coin
928
Audio Sources
X3
AMPs
E17K
DACs
Q1
regtime
2016-7-12

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2018-10-30 10:37:06 |Show all posts |
How to upgrade the X3: https://www.fiio.com/newsinfo/63356.html

Best regards
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
32
F-Coin
123
Audio Sources
na
AMPs
no
regtime
2016-9-27
Post time 2019-5-3 10:24:50 |Show all posts |
Hi, thanks for replying.
I did manage to upgrade the firmware. As you can see by the date of your reply it was ages ago, since then i haven't been back here i don't think.

However! I managed to buy another X3 last week from someone in America and it only has 3.2 fw. so i attempted to put the 3.4 fw on it this morning, without success.
I pressed down the two buttons and it started to update, got just over half way then a message pops up saying check firmware error, then system error.
I turned the player back off, turned it on again but instead of any graphics popping up as usual it was just a lit-up black screen.
Also when it's plugged into the pc it isn't being recognized by the computer anymore.

What do you think happened? The player was playing the last couple of days so everything seemed ok.

Many thanks.
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
1003
F-Coin
100860
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-5-6 17:44:39 |Show all posts |
froufrou replied at 2019-5-3 10:24
Hi, thanks for replying.
I did manage to upgrade the firmware. As you can see by the date of your re ...

Dear friend,

According to our experience, it is a hardware issue with your X3.
But you may still try to change another sd card and update the firmware again to see if it helps.

Best regards
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
32
F-Coin
123
Audio Sources
na
AMPs
no
regtime
2016-9-27
Post time 6 Day Before |Show all posts |
I've tried two other cards but the same things happen. I even tried putting 3.3fw in it instead of the 3.4fw but no joy.
So that was a waste of $150. Took me ages to find someone overseas who was willing to ship an X3 'down under.'
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
1003
F-Coin
100860
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 6 Day Before |Show all posts |
froufrou replied at 2019-5-16 07:17
I've tried two other cards but the same things happen. I even tried putting 3.3fw in it instead of t ...

Dear friend,

You could consider whether sending it back to us for check. Or maybe update to a new product instead.

Best regards
Reply

Use magic Report

You have to log in before you can reply Login | Register Now

About FiiO|Warranty|Contact Us|FiiO Forums  

GMT+8, 2019-5-22 12:44 , Processed in 0.026436 second(s), 22 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

Top