FiiO Forums

 Retrieve Password
Register Now
/Sign In
Search
!show!: 2771|Reply: 23

K3 USB issues

FiiO Fans

digest
0
posts
1
F-Coin
6
Audio Sources
E10, K3
AMPs
E10, K3
regtime
2018-12-23
Post time 2018-12-23 18:30:04 |Show all posts |
Edited by angelclaw at 2018-12-23 18:32

The K3 seems to have some USB issues with Windows 10, in both USB1 driverless and USB2 modes:

- putting the PC in sleep mode without turning the K3 off (sliding volume knob to minimum) will not turn off power to the K3. Waking the PC, despite the K3 still being on, won't make the K3 available to Windows without reconnecting the USB to the K3 or turning the K3 off & on using the volume knob (it doesn't show under device manager).

- rebooting the PC while the K3 is powered will make it inaccessible, needs USB cable reconnect or manually powering the K3 off and then on.


I use the K3 at the same time with my old E10, and the E10 doesn't have these issues.
Can someone reproduce my issues? Can it be fixed with a firmware update?


My main concern is that if I reboot or put my PC in sleep many times in a day, I have to manually operate the K3 so it can be detected under Windows normally, which is a pain in the ass.

Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
866
F-Coin
100631
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2018-12-24 19:00:30 |Show all posts |
Dear friend,

You have reported to us via email and communicated with us,right?

Best regards
Reply

Use magic Report

FiiO Fans

digest
0
posts
2
F-Coin
6
Audio Sources
PC
AMPs
FiiO K3
regtime
2019-1-2
Post time 2019-1-2 19:17:17 |Show all posts |
I can also confirm the same issue on my Windows 10 machine, so it's not an isolated problem. As 'angelclaw' stated, you have to unplug or turn on/off the K3 each time for it to be recognised by Windows 10. Other than that it's a great little DAC/Amp, so a firmware fix would be nice!

ps. works fine on my Windows 7 machine and doesn't exhibit the same problem.
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
866
F-Coin
100631
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-1-3 09:47:26 |Show all posts |
JimmyAK replied at 2019-1-2 19:17
I can also confirm the same issue on my Windows 10 machine, so it's not an isolated problem. As 'ang ...

Dear friend,

I got a feedback from a user had same issue solved by using another usb port. The issue only happens in your Win10 computer? Did you try another usb port as well?

Best regards
Reply

Use magic Report

FiiO Fans

digest
0
posts
2
F-Coin
6
Audio Sources
PC
AMPs
FiiO K3
regtime
2019-1-2
Post time 2019-1-3 16:49:07 |Show all posts |
Thank you for the feedback. I have done some more testing and it does seem to be related to the USB port type. If I plug it into a USB 3.0 port then it works OK. Plugged into a USB 2.0 port then it exhibits the issue. I'll leave it plugged into USB 3.0!
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
866
F-Coin
100631
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-1-7 09:12:39 |Show all posts |
JimmyAK replied at 2019-1-3 16:49
Thank you for the feedback. I have done some more testing and it does seem to be related to the USB  ...

Dear friend,

Maybe it is releated to the power apply of the USB2.0 port in your computer. The K3 works fine in the USB 2.0 port of my computer instead. We will also report to the engineer about that.

Best regards
Reply

Use magic Report

FiiO Fans

digest
0
posts
1
F-Coin
9
Audio Sources
Windows7 USB2
AMPs
K3
regtime
2019-1-18
Post time 2019-1-18 05:06:58 |Show all posts |
Edited by mida at 2019-1-18 08:01

Hello.

My new K3 audibly connects then disconnects from my B&O active speakers each time I play a sound which is causing me a problem in some software I use.

I've recorded a small sound file to illustrate the issue... https://vocaroo.com/i/s0tSVs3M0Cmd. You can hear a beep sound being played (at 2-3 seconds) followed by a pause before the speakers "disconnect" (sound at 8-9 seconds).

I bought the K3 to replace my NuForce Icon 2 which is connected to my computer in exactly the same way but does not suffer from this issue.

I'm running Windows 7 on a machine that only has USB 2 ports - is this the problem? Does the K3 require USB 3 to work properly?

I've installed the K3 driver and the switch on the back is set to USB 2.0.

Any advice much appreciated.
Reply

Use magic Report

FiiO Fans

digest
0
posts
1
F-Coin
7
Audio Sources
dt 990 pro
AMPs
fiio k3
regtime
2019-1-20
Post time 2019-1-21 06:11:50 |Show all posts |
I can also confirm on my computer that Windows does not detect the K3 after turning the computer on. It needs to be unplugged then plugged back in for the K3 to be usable. I tried USB 3.0 and 2.0 ports and both have the same issue.

I did some testing and it seems to be the time the computer is off that is the factor. A short while and it will work fine, but if the computer is turned off for a long time then it will have the red LED and need to be replugged to function.
Reply

Use magic Report

FiiO Fans

digest
0
posts
3
F-Coin
19
Audio Sources
pc
AMPs
k3
regtime
2019-1-25
Post time 2019-1-25 18:38:54 |Show all posts |
hello
i have the same problem as duck
im using k3 dac on win7 64 and i have trouble playing dsd files after restarting computer, i switch usb port reinstall drivers 4.47.0 and is working. after restart  i have to do it all over again.
im using foobar2000 config as specified on website.
any suggestion before i return it to store?
thank you.
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
866
F-Coin
100631
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-1-28 15:14:55 |Show all posts |
duck replied at 2019-1-21 06:11
I can also confirm on my computer that Windows does not detect the K3 after turning the computer on. ...

Dear friend,

Can the K3 be recognized again after turning off and on the volume wheel of the K3?

Best regards
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
866
F-Coin
100631
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-1-28 15:15:11 |Show all posts |
duck replied at 2019-1-21 06:11
I can also confirm on my computer that Windows does not detect the K3 after turning the computer on. ...

Dear friend,

Can the K3 be recognized again after turning off and on the volume wheel of the K3?

Best regards
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
866
F-Coin
100631
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-1-28 15:16:46 |Show all posts |
lucimunteanu replied at 2019-1-25 18:38
hello
i have the same problem as duck
im using k3 dac on win7 64 and i have trouble playing dsd file ...

Dear friend,

Switching the usb port failed to help? The issue you mentioned only happens in DSD files or other files as well?

Best regards
Reply

Use magic Report

FiiO Fans

digest
0
posts
3
F-Coin
19
Audio Sources
pc
AMPs
k3
regtime
2019-1-25
Post time 2019-1-29 22:18:14 from mobile |Show all posts |
I have checked every usb port, 2.0-3.0
Reinstalled Windows from 7 to Windows 10/64bits
Now it works fine on dsd and other losless files, but after restart or shut down it doesnt pop up in Windows, untill is switched off and on again.
It is a pain to do it every time.
Disabled fastboot from bios and Windows, also Disabled usb sleep.
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
866
F-Coin
100631
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-1-30 15:55:15 |Show all posts |
lucimunteanu replied at 2019-1-29 22:18
I have checked every usb port, 2.0-3.0
Reinstalled Windows from 7 to Windows 10/64bits
Now it works  ...

Dear friend,

We have recorded the issue you mentioned. Please give some time for the engineers for checking this. Will update to you after receiving any feedback from them.

Sorry if bringing inconvenience to you.

Best regards
Reply

Use magic Report

FiiO Fans

digest
0
posts
1
F-Coin
3
Audio Sources
k3
AMPs
K3
regtime
2019-1-31
Post time 2019-1-31 17:47:50 |Show all posts |
I also have this problem. When K3 is switched to USB AUDIO 2.0 mode.  The device is not detected by Windows 10 after reboot. I have tried all the usb port on my machine. USB AUDIO 1.0 does not have this issue, however DSD is not supported in USB AUDIO 1.0 mode.
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
866
F-Coin
100631
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-2-20 17:20:40 |Show all posts |
zhui1115 replied at 2019-1-31 17:47
I also have this problem. When K3 is switched to USB AUDIO 2.0 mode.  The device is not detected by  ...

Dear friend,

Thank you for your kind feedback. We will also report to the engineer for check.

Best regards
Reply

Use magic Report

FiiO Fans

digest
0
posts
3
F-Coin
19
Audio Sources
pc
AMPs
k3
regtime
2019-1-25
Post time 2019-2-20 19:36:48 from mobile |Show all posts |
I understand that  "they check", but do we get an answer?
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
1
F-Coin
3
Audio Sources
Spotify
AMPs
FiiO K3
regtime
2019-3-21
Post time 2019-3-21 22:08:23 |Show all posts |
I have similar problem ever since I started using K3.  I'm listening to music mainly on Spotify.  The driver is not working properly on Windows 10.

Spotify is not working properly. Every time I have to trick it to work.
I turn off K3, start playing music on Spotify using default device ( otherwise it is skipping songs and no producing any output).... then I turn on K3 it starts working.  It is fine unless I decide to switch to another device and go back to Windows.
I'm not able to use it using Camtasia Studio 8 - it just doesn't recognize it as a default device.
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
1
F-Coin
9
Audio Sources
iTunes
AMPs
K3
regtime
2019-4-5
Post time 2019-4-5 20:01:37 |Show all posts |
Same problem with iMac 27 2017 on MacOS X (Mojave 10.14.4) - K3 doesn't output anything until being reconnected after long standby. I use it on my workplace and have to reconnect it every morning to get it working. Tried different USB ports - didn't help.
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
4
F-Coin
8
Audio Sources
K3
AMPs
K3
regtime
2019-4-13
Post time 2019-4-13 16:53:50 |Show all posts |
K3 installed with the latest driver on windows 10.

Please help urgently, my K3 will simply stop working although it is shown as connected to my computer. i.e, I was playing music via spotify/youtube etc, maybe 10 mins or so it will stop. I will need to "off and on" K3 before it starts again....

I cant be doing this every 10 mins.....

Please save me...
Reply

Use magic Report

You have to log in before you can reply Login | Register Now

About FiiO|Warranty|Contact Us|FiiO Forums  

GMT+8, 2019-4-25 22:42 , Processed in 0.034944 second(s), 22 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

Top