FiiO Forums

 Retrieve Password
Register Now
/Sign In
Search
!show!: 527|Reply: 6

X7 mkII - Issues with Tidal update

FiiO Fans

digest
0
posts
2
F-Coin
7
Audio Sources
Fiio X7 mkII
AMPs
Fiio X7
regtime
2019-1-8
Post time 2019-1-8 23:34:09 |Show all posts |
Has anyone else tried Tidal after the latest update (with MQA integration)? Tidal gave me nothing but pure distortion for all MQA and non-MQA songs I tried to play. Even the tracks that I had downloaded a while ago to the device were heavily distorted. Tidal is now useless for me on the X7 Mk II. Anyone else having the same issues?
Reply

Use magic Report

FiiO Fans

digest
0
posts
1
F-Coin
7
Audio Sources
Tidal
AMPs
X7Mii
regtime
2019-1-8
Post time 2019-1-8 23:56:46 |Show all posts |
Yes! Mee too. Glad I am not the only one. Sad that it is happening....
Reply

Use magic Report

FiiO Fans

digest
0
posts
11
F-Coin
76
Audio Sources
TIDAL
AMPs
FiiO X5 3
Head Gears
Brainwavz B400 / Sennheiser Momentum
regtime
2018-8-20
Post time 2019-1-9 00:50:26 |Show all posts |
Edited by wreedheid at 2019-1-9 03:04

My device is the X5 III, issues are the same.

I'm on the beta firmware (beta-1.2.2) and thought it was just me. TIDAL is completely useless, even when playing non-MQA songs the distortion is there. Are you guys on the non-beta firmware, 1.2.1?

I really hope that FiiO or TIDAL fixes this ASAP, makes the device almost completely useless...

edit: TIDAL is set to *not* use Master quality and it still happens (after a reboot of both the app and the device) on both the 3.5 mm as 2.5 mm output.
Reply

Use magic Report

FiiO Fans

digest
0
posts
2
F-Coin
7
Audio Sources
Fiio X7 mkII
AMPs
Fiio X7
regtime
2019-1-8
Post time 2019-1-9 01:05:42 |Show all posts |
I'm on the non-beta firmware (1.0.6 I believe). Based on some head-fi forums it appears that this might just be a Fiio issue since other instance of Android are working.
Reply

Use magic Report

FiiO Fans

digest
0
posts
11
F-Coin
76
Audio Sources
TIDAL
AMPs
FiiO X5 3
Head Gears
Brainwavz B400 / Sennheiser Momentum
regtime
2018-8-20
Post time 2019-1-9 03:08:28 |Show all posts |
Completely reinstalled the device back from the beta-fw to the latest version, 1.2.1. Installed TIDAL, distortion is still there. Really hope that FiiO will bring out a fix or at least respond / update us in the next couple of days.
Reply

Use magic Report

FiiO Fans

digest
0
posts
11
F-Coin
76
Audio Sources
TIDAL
AMPs
FiiO X5 3
Head Gears
Brainwavz B400 / Sennheiser Momentum
regtime
2018-8-20
Post time 2019-1-9 21:47:29 |Show all posts |
New update from TIDAL is in the Google Play Store: fixed it for me (X5 III - 1.2.1)
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
757
F-Coin
100466
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-1-10 10:15:27 |Show all posts |
Edited by FiiO at 2019-1-10 10:16

Dear friend,

Yes. Tidal has fixed their issue by themselves instead.

Best regards



Reply

Use magic Report

You have to log in before you can reply Login | Register Now

About FiiO|Warranty|Contact Us|FiiO Forums  

GMT+8, 2019-3-20 04:44 , Processed in 0.033805 second(s), 22 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

Top