FiiO Forums

 Retrieve Password
Register Now
/Sign In
Search
!show!: 2030|Reply: 8

Fiio K3 click/popping noise when audio starts/stops

FiiO Fans

digest
0
posts
1
F-Coin
6
Audio Sources
PC
AMPs
Fiio K3
regtime
2019-1-23
Post time 2019-1-23 06:36:09 |Show all posts |
got a Fiio K3 yesterday and whenever audio starts/stops it makes a click/popping noise which can get a little bit annoying if switching audios/videos frequently, I was just wondering if this is normal or if my unit could be faulty?



Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
1213
F-Coin
101178
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-1-24 18:28:08 |Show all posts |
Dear friend,

There is a electronic switch in the K3 for avoiding the impulse sound, which may make a slight pop after stopping the music. If your issue is similar like that, please don't worry. The slight pop is not quite noticeable as well.

Best regards
Reply

Use magic Report

FiiO Fans

digest
0
posts
1
F-Coin
11
Audio Sources
Mac
AMPs
K3, E10K
regtime
2019-1-31
Post time 2019-1-31 05:56:12 |Show all posts |
Hallo,

i have the same problem. I use the k3 the hole day long at my mac so this is very annoying. Espacally if the system plays a notification sound or something else with a short runtime. Is it possible to fix this with software?  
Reply

Use magic Report

FiiO Fans

digest
0
posts
1
F-Coin
3
Audio Sources
PC
AMPs
Fiio K3
regtime
2019-2-5
Post time 2019-2-5 18:12:50 |Show all posts |
I've got the same problem on my new Fiio K3. A clear click/pop noise at the start and end of all sound clips. Very annoying in Skype, Discord etc. with the notice sound on each message.

I have tried both USB AUDIO 1.0 and 2.0 (with driver), different sample/bitrates but the problem remains. My previous Fiio K10 had the same exact problem and it was the reason I sold it. I was hoping this would have been fixed with K3 but now I'm stuck with the same problem again.
My Audinst HUD-Mini does not have this problem, so it only seems to be present on Fiio products.

Is there any fix to this or should I return the unit as defective?
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
1213
F-Coin
101178
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-2-20 18:49:36 |Show all posts |
Dear friend,

I am not sure whether this could help, but you may try:

C:\Program Files\FiiO\FiiO_Driver\W7W8_x86, replace 'FiiOCplApp.xml' file(unzip first) with the attachement to see if it helps.

Then set FiiO control panel- option-streaming to 'always'.


Best regards

FiiOCplApp.zip

855 Bytes, Downloads: 126

Reply

Use magic Report

Intermediate Member

Rank: 3Rank: 3

digest
0
posts
2
F-Coin
260
Audio Sources
Computer
AMPs
FiiO K3
regtime
2019-3-31
Post time 2019-3-31 23:53:40 |Show all posts |
Edited by firealpaca at 2019-4-1 00:03

Hi,

I just got my K3 and also encountered this problem, and fixed it as you suggested by setting "Streaming" to "Always On". Perhaps this should be set as the default option?

It also fixed another bigger problem, where if I didn't play any audio for about 10 seconds, the K3 seemed to go to sleep with a pop (I guess this is when the driver stops streaming), and then the first quarter second of any audio played afterwards would get cut off while it wakes up. Someone else seems to have a similar problem here http://fiio.me/forum.php?mod=viewthread&tid=44213

For anyone else who has this problem, here's what I did:
1) Download and install the K3 driver/control panel from https://fiio.com/k3_faq
2) Enable the hidden control panel settings by editing C:\Program Files\FiiO\FiiO_Driver\W10_x64\FiiOCplApp.xml (disable read-only and open your text editor as administrator) and change PageOptions's <Visibility> setting from "Hidden" to "Visible". (Or replace the file with the attachment in the post above.)
3) Restart the control panel, and then in Options->Streaming, change "On when Needed" to "Always On"
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
3
F-Coin
12
Audio Sources
iMac
AMPs
K3
regtime
2019-4-27
Post time 2019-4-27 20:19:25 |Show all posts |
Edited by cmitchel at 2019-5-2 09:49
FiiO replied at 2019-2-20 18:49
Dear friend,

I am not sure whether this could help, but you may try:

Hello,

I have just purchased a K3 and have this problem, but I use an iMac, which uses it's own OSX drivers for the K3.

Is there a way to switch streaming to Always On on the Mac? If so how please?

I am delighted with the K3 sound quality but will have to return it if I cannot remove the the popping noise when the unit starts and stops decoding.

Thanks, Chris


Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
3
F-Coin
9
Audio Sources
USB
AMPs
K3
regtime
2019-5-16
Post time 2019-5-16 21:31:12 |Show all posts |
I have the same issue on Mac. Please tell us how to turn on "Always streaming on" for a Mac!
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
1
F-Coin
9
Audio Sources
PC, Mac
AMPs
E10K, K3
regtime
2019-5-18
Post time 2019-5-18 18:33:39 |Show all posts |
@FiiO

An optional firmware update that sets Streaming to "Always On" by default in the K3 itself on a hardware level would've been just perfect for those of us bothered by this issue.

For me, the K3 goes to sleep instantly as the sound ends, so using it on a Mac is very inconvenient. Pusing/resuming a YouTube video, for example, cuts the first ~500ms of audio, so I would often have to rewind to hear what was said in the video. Add to that the fact that no matter what music track or video I play, I will never hear the first few moments of it with the K3.

As of right now, using it anywhere but on a PC with Windows and the manual Streaming setting is very annoying, keeps you wondering what sounds you're missing all the time.
Reply

Use magic Report

You have to log in before you can reply Login | Register Now

About FiiO|Warranty|Contact Us|FiiO Forums  

GMT+8, 2019-7-19 18:07 , Processed in 0.030369 second(s), 25 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

Top