FiiO Forums

 Retrieve Password
Register Now
/Sign In
Search
!show!: 1606|Reply: 8

x7 mkII hissing and crackling sound

FiiO Fans

Rank: 1

digest
0
posts
5
F-Coin
18
Audio Sources
x7 mkII
AMPs
3 and 5
regtime
2019-11-9
Post time 2019-11-9 20:02:24 |Show all posts |
started yestrday. did a full wipe . switched amps nothing works. its crackling at any volume and hissing which continues for a few seconds after the music stops. help pls
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
3348
F-Coin
104033
DACs
FiiO Q5s
Head Gears
FiiO FA9
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-11-11 16:57:52 |Show all posts |
Dear friend,

Which outout are you using? Did you try the factory restore and another headphones to see if it helps?

Best regards
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
5
F-Coin
18
Audio Sources
x7 mkII
AMPs
3 and 5
regtime
2019-11-9
Post time 2019-11-11 19:54:28 |Show all posts |
FiiO replied at 2019-11-11 16:57
Dear friend,

Which outout are you using? Did you try the factory restore and another headphones to  ...

using the normal 3.5. iv tried all sorts of headphones. i believe this is a hardware issue. how can i get it fixed ?
my location is : Israel
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
5
F-Coin
18
Audio Sources
x7 mkII
AMPs
3 and 5
regtime
2019-11-9
Post time 2019-11-12 22:09:38 |Show all posts |
tombar replied at 2019-11-11 19:54
using the normal 3.5. iv tried all sorts of headphones. i believe this is a hardware issue. how ca ...

cant u please  contact me on my email : tomerb666@gmail.com
thank you
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
5
F-Coin
18
Audio Sources
x7 mkII
AMPs
3 and 5
regtime
2019-11-9
Post time 2019-11-13 17:15:41 |Show all posts |
tombar replied at 2019-11-11 19:54
using the normal 3.5. iv tried all sorts of headphones. i believe this is a hardware issue. how ca ...

what`s going on ? am i suppose to just wait for a response ? how long ?
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
3348
F-Coin
104033
DACs
FiiO Q5s
Head Gears
FiiO FA9
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-11-14 15:24:38 |Show all posts |
Dear friend,

We have provided the address to you via email.

Best regards
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
5
F-Coin
18
Audio Sources
x7 mkII
AMPs
3 and 5
regtime
2019-11-9
Post time 2019-11-14 22:17:49 |Show all posts |
Edited by tombar at 2019-11-14 22:22
FiiO replied at 2019-11-14 15:24
Dear friend,

We have provided the address to you via email.
ok got it i will sent it asap
Reply

Use magic Report

FiiO Fans

digest
0
posts
13
F-Coin
174
Audio Sources
Fiio X7mkII
AMPs
AM5
regtime
2019-2-27
Post time 2019-11-18 18:33:38 |Show all posts |
I just started having the exact same issue on my X7II.....Any update on what the issue is? I also fear that this is a hardware problem...
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
3348
F-Coin
104033
DACs
FiiO Q5s
Head Gears
FiiO FA9
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2019-11-19 10:56:39 |Show all posts |
Dear friend,

Did you try the factory restore or other headphone first?

Best regards
Reply

Use magic Report

You have to log in before you can reply Login | Register Now

About FiiO|Warranty|Contact Us|FiiO Forums  

GMT+8, 2020-7-14 21:36 , Processed in 0.024908 second(s), 25 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

Top