FiiO Forums

 Retrieve Password
Register Now
/Sign In
Search
!show!: 3257|Reply: 19

M6 stuttering... assume card

Register Member

Rank: 2

digest
0
posts
23
F-Coin
131
Audio Sources
M6, X3, X1 - various iPod using lossless
AMPs
BTR5, BTR3, uBTR, Q1mkII, E7, E17, E9
DACs
D3, D03K
Head Gears
Senn's HD600,HD650,HD595,HD598,HD58x Jubilee and another dozen Senns from the last 30 years - Audio-Technica ATH-M40x
regtime
2015-1-28
Post time 2020-3-6 22:28:32 |Show all posts |
Been using M6 for some time now and my SD card is getting full (about 10GB free) after adding some music it seems to be stuttering at the beginning of songs, newly added and older ones, also if playing music and I go back to album view it stutters as loading the album artwork.

My music is in ALAC and have about 4000+ on the card.

Question:

1. its seems the M6 does not buffer the music, can anyone confirm it does that or not, I feel if the music app buffered this would not happen.  Question for FiiO, perhaps add a buffer option like some streaming radio apps have

2. Does the M6 not like certain cards?

3. Does album artwork size affect anything, my music is from iTunes lib so when Ive added some artwork myself they can be large 1000x1000 pixels. But I try to keep them around 500x500 if I'm adding them.

Cards that give me this behaviour SandDisk Ultra, (swapped that out within a few days of getting the player), Samsung Evo, my curent card is Patriot V30 A1 card (this was good until recently, it didnt stutter until now so I assume it was fast enough, the other cards shuld have been fast enough really)

Just odered two different Kingston card (canvas react and canvas select) after some googling this seems to be a good brand for this player. Can anyone confirm.
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
6
F-Coin
41
Audio Sources
MP3/FLAC
AMPs
M6
regtime
2020-1-21
Post time 2020-3-8 20:46:41 |Show all posts |
I have the same problem, but it only seems to affect me when playing lossless format music, either FLAC or DSD.
The latency seems to subside after around 15 seconds into each song, but it's extremely annoying.
I'm becoming steadily disenchanted with my M6 because of the latency issue and because the Music app crashes almost every time I use it.
I sure hope that Fiio has a proper fix for these two issues in a forthcoming firmware, because if they don't, I'm just about to throw my M6 in the trash out of frustration.
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
3665
F-Coin
104492
DACs
FiiO Q5s
Head Gears
FiiO FA9
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2020-3-9 22:23:58 |Show all posts |
Hello,

Sorry about this problem.
What's the firmware version of your M6?
And does the problem related to certain music or format? Or the issue only happen when there are certain quantity of music files in the card?

Best regards
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
23
F-Coin
131
Audio Sources
M6, X3, X1 - various iPod using lossless
AMPs
BTR5, BTR3, uBTR, Q1mkII, E7, E17, E9
DACs
D3, D03K
Head Gears
Senn's HD600,HD650,HD595,HD598,HD58x Jubilee and another dozen Senns from the last 30 years - Audio-Technica ATH-M40x
regtime
2015-1-28
Post time 2020-3-10 05:16:42 |Show all posts |
1.0.3

All my music is in .M4A (ALAC) it happens with all files but more so with higher bitrates, so 24/96 or 24/192.

Its also mainly in Album view, this is how I use the M6.

After I changed to the Kingston Canvas Select Plus (256GB) is has got much better, but still does it if playing a 24bit track and again scrolling in album view.
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
3665
F-Coin
104492
DACs
FiiO Q5s
Head Gears
FiiO FA9
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2020-3-10 16:01:49 |Show all posts |
We will report to the engineer and try to reproduce your problem first.
Please accept our sincere apology for all the inconvenience bringing to you.

Best regards
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
6
F-Coin
41
Audio Sources
MP3/FLAC
AMPs
M6
regtime
2020-1-21
Post time 2020-3-12 06:42:45 |Show all posts |
FiiO replied at 2020-3-9 22:23
Hello,

Sorry about this problem.

I have the latest firmware, 1.0.3.
I just did a little more digging by playing the same files via normal wired earbuds and the latency problem is not there at all with those, so this is clearly an issue with the wireless earbuds that I use most of the time, which consist of Fiio UTWS1 bluetooth adapters with some generic earbuds that plug into the micro MCX connectors.
It's clear to me that the latency issue is only present when playing high resolution audio (FLAC 44.1Khz or DSD audio) via this bluetooth setup.
As I said, there is no such latency when using wired earbuds.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
23
F-Coin
131
Audio Sources
M6, X3, X1 - various iPod using lossless
AMPs
BTR5, BTR3, uBTR, Q1mkII, E7, E17, E9
DACs
D3, D03K
Head Gears
Senn's HD600,HD650,HD595,HD598,HD58x Jubilee and another dozen Senns from the last 30 years - Audio-Technica ATH-M40x
regtime
2015-1-28
Post time 2020-3-13 09:02:01 |Show all posts |
oldpink replied at 2020-3-11 17:42
I have the latest firmware, 1.0.3.
I just did a little more digging by playing the same files via  ...

Intersting I'm using LDAC, let me try without using bluetooth and see if it still stutter, for me its basically when it loading the album art. The music will stutter as the graphics show. I alway use album view.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
23
F-Coin
131
Audio Sources
M6, X3, X1 - various iPod using lossless
AMPs
BTR5, BTR3, uBTR, Q1mkII, E7, E17, E9
DACs
D3, D03K
Head Gears
Senn's HD600,HD650,HD595,HD598,HD58x Jubilee and another dozen Senns from the last 30 years - Audio-Technica ATH-M40x
regtime
2015-1-28
Post time 2020-3-14 05:54:28 |Show all posts |
So I tried it not using bluetooth and it works normal, I only once got a little blip as I was shipping tracks. But no stuttering when browsing in album view playing music using the headphone jack and wired headphones, So it does only happen when using bluetooth.

Tonight I will try using it as a transport and external USB DAC, then again tried wired and wireless headphones .

Just so you know in wireless LDAC I'm pairing the M6 with BTR5
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
3665
F-Coin
104492
DACs
FiiO Q5s
Head Gears
FiiO FA9
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2020-3-14 16:04:31 |Show all posts |
So the stutter happens in Bluetooth when playing high sampling rate music files?

Best regards
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
23
F-Coin
131
Audio Sources
M6, X3, X1 - various iPod using lossless
AMPs
BTR5, BTR3, uBTR, Q1mkII, E7, E17, E9
DACs
D3, D03K
Head Gears
Senn's HD600,HD650,HD595,HD598,HD58x Jubilee and another dozen Senns from the last 30 years - Audio-Technica ATH-M40x
regtime
2015-1-28
Post time 2020-3-14 23:11:21 |Show all posts |
FiiO replied at 2020-3-14 03:04
So the stutter happens in Bluetooth when playing high sampling rate music files?

Best regards

Yes, but does not need to be high sample rate (it stutter more with high sampling rate), will do it with all types 16/44.1, Im only using LDAC will try with a lower quality bluetooth setting.

Tried today with a external USB doc and it does not stutter.

Only stutters with LDAC using bluetooth when paired to my BTR5 ( this is on firmware 1.0.6 ) when playing music and browsing album view and its during the times the album art is loading.
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
3665
F-Coin
104492
DACs
FiiO Q5s
Head Gears
FiiO FA9
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2020-3-16 15:34:36 |Show all posts |
We will check first.
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
1
F-Coin
3
Audio Sources
Fiio M6
AMPs
A5
regtime
2020-7-20
Post time 2020-7-20 21:50:51 |Show all posts |
Hi everyone! Thank God some people are having the same issues.
In my case, the stutter only occurs when playing DSD files, regardless of whether is bluetooth or line out (I use primarily line out).
At first I could solve the problem by pausing the music and then resuming. It all started right away and beautifully. But when I got to the next song, the same stuttering happens and I need to do the same "pause/resume" action.
Someone out there suggested it might had to do with internal memory usage, so I cleared the cache, disconnected WIFI and Bluetooth, and although I still need to do the "pause/resume" action, i can now play files that I could not before. Curiously, before "cleaning the memory" I could only solve the issue for piano music, but with orchestras I was absolutely doomed. Now I can play the orchestras as well...
I really hope this can be solved with a new firmware update!! I am currently using the latest 1.0.4.

Thanks in advance for your response, and let me know if you need more info for the engineers.

Best,

Manuel
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
4
F-Coin
18
Audio Sources
Flac, mp3
AMPs
M6
regtime
2020-9-4
Post time 2020-9-4 01:08:49 |Show all posts |
Hi, same problem here, audio stuttering for the first few seconds, then everything is okay. Curiously it seems less noticeable with flac than with mp3 and in built-in app instead of MediaMonkey.

The problem is non-existent with wired connection.
I hope this will get fixed because it is really annoying problem with quite a nice player (M6, os v1.0.4) other than that.
Reply

Use magic Report

Register Member

Rank: 2

digest
0
posts
23
F-Coin
131
Audio Sources
M6, X3, X1 - various iPod using lossless
AMPs
BTR5, BTR3, uBTR, Q1mkII, E7, E17, E9
DACs
D3, D03K
Head Gears
Senn's HD600,HD650,HD595,HD598,HD58x Jubilee and another dozen Senns from the last 30 years - Audio-Technica ATH-M40x
regtime
2015-1-28
Post time 2020-9-5 09:44:55 |Show all posts |
Ended up with a Kingston Card for mine it helped the problem its the fastest one they make for read speed, its still happens but much less. Its still a software issue I feel they need to buffer more of the track during playback. Loading the cached album art is whats doing it. The software is not efficient.

I noticed its worse with larger file formats, 24 bits its worse its the music DATA stream if its gets interrupted playing like it seem to as it loads album art then it stutters, again bad coding it should be buffered better or something, the faster SD card help for sure. But why should we need to buy much more expensive cards to help the issue.

Im starting to think I should jump to a different brand of DAP, I just got a M3 Pro to test and nice little player and I thought no Android its got to be better, that does not show song on each album in the correct order for some reason. It does not show album art in list view like the M6 so no stuttering on playback.

FiiO software QA need to be better or get better coders working on this stuff.
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
3665
F-Coin
104492
DACs
FiiO Q5s
Head Gears
FiiO FA9
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 2020-9-8 10:51:51 |Show all posts |
FRK replied at 2020-9-4 01:08
Hi, same problem here, audio stuttering for the first few seconds, then everything is okay. Curiousl ...

Dear user,

Do you mean that when using the Bluetooth output, the first few seconds is stuttering? What's the app version of your M6? MP3 files having the problem? Would you mind sharing the music files to us for check?

Best regards
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
4
F-Coin
18
Audio Sources
Flac, mp3
AMPs
M6
regtime
2020-9-4
Post time 2020-9-15 04:01:41 |Show all posts |
For me it's M6 os 1.0.4 with mediamonkey downloaded from FiiO website (version 1.3.4.0845). SD card is SanDisk Ultra, 64GB class 10. I noticed the problem with multiple files, but more often with the ones that begin rather aggressively (most of my tracks start quietly). The one in particular was this one in mp3 variant https://ozoithemaid.bandcamp.com/track/wonderland (alone its 1$, the whole album is free). If I can be of any help please let me know, I'd love this fixed.
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
3665
F-Coin
104492
DACs
FiiO Q5s
Head Gears
FiiO FA9
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 7 Day Before |Show all posts |
Dear user,

You may need to contact the support of Media monkey or try to update this app to check again?

Best regards
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
4
F-Coin
18
Audio Sources
Flac, mp3
AMPs
M6
regtime
2020-9-4
Post time 6 Day Before |Show all posts |
I'm sorry for not explaining properly: both the built-in application and Media Monkey have the issue,  although it is less noticeable with built-in app. I believe that it is actually a software issue, although the MediaMonkey app is indeed quite old. I downloaded it from here: https://www.fiio.com/newsinfo/91534.html
As much as I'd like to update it, any version higher than provided ends with error because of too low version of playstore services. Please let me know if there is a way to update it. Also let me know if I should start a separate thread.
Best regards
Reply

Use magic Report

Super Moderator

Born for music and happy

Rank: 8Rank: 8

digest
3
posts
3665
F-Coin
104492
DACs
FiiO Q5s
Head Gears
FiiO FA9
regtime
2013-5-10

Medal of X3 Senator if Forums Honorary Admin Excellent Moderator Outstanding Contributors King of Chatting Master of Publictity Master of Promotion Enthusiastic Member Active Member Supernova

Post time 6 Day Before |Show all posts |
The music will have stutter when using FiiO Music app? You could also share some music files to us for check.

Best regards
Reply

Use magic Report

FiiO Fans

Rank: 1

digest
0
posts
4
F-Coin
18
Audio Sources
Flac, mp3
AMPs
M6
regtime
2020-9-4
Post time 6 Day Before |Show all posts |
Samples: https://mega.nz/folder/RLYUjaQK#PKR0Qqpzy-9rdTI8kqvxag
Steps to reproduce:
1. Play one of the files through bluetooth (I am using aptx)
2. Issue also present if rewinding to beginning few seconds into start
Reply

Use magic Report

You have to log in before you can reply Login | Register Now

About FiiO|Warranty|Contact Us|FiiO Forums  

GMT+8, 2020-9-23 17:51 , Processed in 0.026682 second(s), 23 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

Top